Monitoring
Some members may still be experiencing an issue with Chase. Please try resetting your Chase password and logging in again.
Investigating
We're working to resolve two issues with Chase.
1. Members have reported being stuck in a login loop
2. Members have reported Sapphire cards not syncing despite their Chase account and other cards syncing. We're working on resolving both of these issues.